Задать вопрос
24 апреля, 22:22

Дни недели пронумерованы следующим образом: 0-воскресенье, 1-понедельник, 2-вторик и т. д. Известно, что первое число месяца был понедельник. Определите какой день был в N дату (N<=31)

+2
Ответы (1)
  1. 25 апреля, 00:07
    0
    program zz1;

    var k:integer; / / задаем переменную целого типа

    begin

    write (' введите день месяца ');

    read (k); / / вводим с клавиатуры число

    if k mod 7 = 1 then write (' понедельник '); / / проверяем введенное число и выводим ответ

    if k mod 7 = 2 then write (' вторник ');

    if k mod 7 = 3 then write (' среда ');

    if k mod 7 = 4 then write (' четверг ');

    if k mod 7 = 5 then write (' пятница ');

    if k mod 7 = 6 then write (' суббота ');

    if k mod 7 = 0 then write (' воскресенье ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дни недели пронумерованы следующим образом: 0-воскресенье, 1-понедельник, 2-вторик и т. д. Известно, что первое число месяца был ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Кристина всегда говорит правду по понедельникам, средам и пятницам. В остальные дни недели она всегда врет. Сегодня она сказала: "Завтра я буду говорить правду." Какой сегодня день недели? Варианты ответа понедельник, суббота, воскресенье
Ответы (1)
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)
Дано целое число k. Определите, каким будет k-й день года: выходным (суббота и воскресенье) или будним (понедельник, вторник, среда, четверг, пятница), если 1 января - понедельник (На паскале)
Ответы (1)
Компьютерный вирус А повреждает 1 Гб памяти за один месяц, вирус Б повреждает 1 Гб памяти за 2 месяца, вирус С повреждает 1 Гб памяти за 3 месяца, вирус Д повреждает 1 Гб памяти за 6 месяцев.
Ответы (1)
В месяце апреле 30 дней. 1 апреля - понедельник, 2 апреля - вторник, ... Написать программу, в которой по введеному с клавиатуры дню месяца (например, 15 или 18) вы должны определить какой это день недели. Решить в паскале.
Ответы (1)