Задать вопрос

Массив состоит из 20 целых положительных и отрицательных чисел, каждое из которых находится в пределах от 2 до 12. Вывести на экран сначала отрицательные, а затем положительные числа. Определите, модуль суммы каких чисел больше - положительных или отрицательных.

+5
Ответы (1)
  1. 4 октября, 22:33
    0
    program summ;

    var a: array [1 ... 20] of integer;

    znak, sn, sp: integer;

    begin

    randomize;

    sn: = 0; sp: = 0;

    for i: integer: = 1 to 20 do

    begin

    znak: = random (2) + 1;

    a[i]: = random (11) + 2;

    if znak = 1 then a[i]: = - a[i];

    write (a[i] : 4)

    end;

    writeln ();

    for i: integer: = 1 to 20 do

    begin

    if a[i] < 0 then

    begin

    write (a[i] : 4);

    sn: = sn + a[i]

    end

    end;

    writeln ();

    for i:integer : = 1 to 20 do

    begin

    if a[i] > 0 then

    begin

    write (a[i] : 4);

    sp: = sp + a[i]

    end

    end;

    writeln ();

    writeln (' Сумма положительных чисел: ', sp);

    writeln (' Сумма отрицательных чисел: ', sn);

    if abs (sn) > sp then write (' Модуль суммы отрицательных чисел больше.');

    if abs (sn) < sp then write (' Модуль суммы положительных чисел больше.');

    if abs (sn) = sp then write (' Модули сумм равны.')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Массив состоит из 20 целых положительных и отрицательных чисел, каждое из которых находится в пределах от 2 до 12. Вывести на экран сначала ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Введите с клавиатуры одномерный массив А (N), элементами которого являются положительные и отрицательные целые числа. Подсчитайте произведение положительных элементов этого массива и количество отрицательных.
Ответы (1)