Задать вопрос

Написать программу подсчёта числа отрицательных элементов массива

+4
Ответы (1)
  1. 23 января, 16:11
    0
    Основная часть: в цикле со счетчиком задаем условие - если очередной элемент массива меньше 0, то увеличиваем значение счетчика на 1 (k:=k+1). Последнее значение k подается на печать.

    var

    A: array [1 ... 100] of real;

    k, i, N: integer;

    begin

    for i:=1 to N do

    readln (A[i]);

    k:=0;

    for i:=1 to N do

    if A[i]<0 then k:=k+1;

    writeln ('Число отрицательных элементов массива равно ', k);

    readln

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу подсчёта числа отрицательных элементов массива ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Написать программу на языке паскаль подсчета суммы всех отрицательных элементов массива размерностью 100 элементов
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)