Задать вопрос

Составьте программу для нахождения минимального элемента массива Х, состоя - щего из 6 элементов, значения которых рассчитываются по формуле X = (sini-1) / 2cosi+1 Язык Турбо Паскаль

+1
Ответы (1)
  1. 16 января, 19:11
    0
    const

    N = 6;

    var

    i: integer;

    x: array[1 ... N] of double;

    min: double;

    begin

    //формируем массив в соответствии с условием

    for i : = 1 to N do

    x[i] : = (sin (i) - 1) / (2*cos (i)) + 1;

    min : = x[1]; / / минимуму присваиваем значение первого элемента массива

    / / Проверяем массив, начиная со второго элемента

    / / если текущий элемент меньше минимума

    / / то минимуму присваиваем значение текущего элемента

    for i : = 2 to N do

    if x[i] < min then min : = x[i];

    writeln ('Минимальное значение = ', min);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу для нахождения минимального элемента массива Х, состоя - щего из 6 элементов, значения которых рассчитываются по ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Составить алгоритм и программу подсчитывающую количество меньших чем соседние элементов массива Z из 13 чисел. Значения элементов массива рассчитать по формуле WSinW, где W номер элемента массива
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. В одномерном массиве из 10 целых чисел вычислить количество отрицательных элементов в каждой десятке элементов. 2. Определить сумму минимального и максимального элементов массива из 20 действительных чисел. 3. Дан массив из 20 целых чисел.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)