Задать вопрос

Написать программу которая подсчитывает количество элементов равных к еденице!

+3
Ответы (2)
  1. 17 мая, 14:46
    0
    program zz1;

    const n = 50; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21) - 10;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if m[i] = 1 then k:=k + 1; / / подсчитываем элементы равные 1

    writeln (' элементов равных единице = ', k); / / выводим ответ

    end.
  2. 17 мая, 16:16
    0
    Program marrs1;

    var a:array[1 ... 100] of integer;

    i, k, n:integer;

    Begin

    randomize;

    k:=0;

    writeln ('Введите размерность массива', n);

    readln (n);

    for i:=1 to n do

    a[i]:=random (10) + 1; readln;

    for i:=1 to n do

    begin if a[i]=1 then

    k:=k+1;

    end;

    writeln ('k=', k);

    readln;

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу которая подсчитывает количество элементов равных к еденице! ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы