Задать вопрос
4 мая, 14:13

Значение элементов двумерного целочисленного массива В, оба индекса которого меняются в пределах от 1 до 12, задаются с помощью двойного цикла, представленного следующим фрагментом программы: В[1,1]:=2; For k:=2 to 12 do For n:=1 to k do Begin B[k, n]:=n*k-B[k-1, n]; B[n, k]:=B[k, n]; End; Сколько в этом массиве окажется чётных чисел? В ответе укажите только число, без пробелов и каких-либо знаков препинания, например 100

+4
Ответы (1)
  1. 4 мая, 17:06
    0
    Допишем программу и исполним её в компиляторе:

    var b: array[1 ... 100, 1 ... 100] of integer;

    k, x, n: integer;

    begin

    В[1,1]:=2;

    For k:=2 to 12 do

    For n:=1 to k do

    Begin

    B[k, n]:=n*k-B[k-1, n];

    B[n, k]:=B[k, n];

    End;

    for k : = 1 to 12 do

    for n : = 1 to k do if b[n, k] mod 2 = 0 then x : = x + 1;

    writeln (x);

    end.

    На выходе программа вывела число 39.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Значение элементов двумерного целочисленного массива В, оба индекса которого меняются в пределах от 1 до 12, задаются с помощью двойного ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного цикла в представленном фрагменте программы: Паскаль Алгоритмический язык for i:=1 tо 5 do for j:=1 tо 5 do begin A[i, j]: = i + j; end;
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)