Задать вопрос

Составить программу решения квадратичного уравнения заданными коэфицентами a, b, c. В Паскаль.

+4
Ответы (1)
  1. 21 июня, 22:47
    0
    var a, b, c, d, x1, x2, x:real; begin writeln ('Введите коэффициенты'); readln (a, b, c); d:=sqr (b) - (4*a*c); if d<0 then writeln ('Нет корней'); if d=0 then begin x:=-b / (2*a); writeln ('Корень уравнения = ', x); end else begin x1: = (-b+sqrt (d)) / (2*a); x2: = (-b-sqrt (d)) / (2*a); writeln ('Первый корень уравнения = ', x1); writeln ('Второй корень уравнения = ', x2); end; end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу решения квадратичного уравнения заданными коэфицентами a, b, c. В Паскаль. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы