Задать вопрос

Вычислить: у=1*3*5 * ... * (2n-1), n>0. Написать программу (циклический алгоритм).

+3
Ответы (1)
  1. var n, i:integer; s:real;

    begin

    readln (n);

    s:=0;

    for i:=0 to n do s:=s+1 / (2*i+1);

    writeln ('s = ', s);

    end.

    Пример:

    5

    s = 1.878210678210678e+00
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить: у=1*3*5 * ... * (2n-1), n>0. Написать программу (циклический алгоритм). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить циклический алгоритм вычисления среднего арифметического значения всех четных чисел от 0 до 20
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)
Написать алгоритм: Даны 2 числа a и b оба вводятся с клавиатуры, написать алгоритм нахождения наибольшего из них
Ответы (1)