Задать вопрос
25 апреля, 00:34

Составить программу, которая формирует массив А из 85 случайных целых чисел, принадлежащих промежутку [4; 14]. Параметром цикла является переменная s. Нумерация начинается с 1

+3
Ответы (1)
  1. 25 апреля, 02:07
    0
    При выводе использовано условие: если параметр s (номер позиции в массиве) кратный число 10, то начинать вывод с новой строки.

    Строку с условием можно заменить строкой: write (A[s]:3). Будет осуществлен вывод без разбивки на строки.

    program array_;

    var A:array [1 ... 85] of integer;

    begin

    randomize;

    for s: integer:=1 to 85 do

    begin

    A[s]: = random (11) + 4;

    / / random (11) - генерирует случайное число от 0 до 11, исключая число 11

    if s mod 10 = 0 then writeln (A[s]:3) else write (A[s]:3);

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая формирует массив А из 85 случайных целых чисел, принадлежащих промежутку [4; 14]. Параметром цикла является ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы