Задать вопрос
14 октября, 04:54

найти сумму положительных нечетных чисел, меньших n. по паскалю

+4
Ответы (1)
  1. 14 октября, 06:46
    0
    program zz1;

    var i, n, s:integer; / / задаем переменные целого типа для цикла

    begin

    write (' введите заданное число n '); / / вводим с клавиатуры последнее число ряда

    read (n);

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    if i mod 2 = 1 then s:=s + i; / / проверяем, если очередное число при делении на два дает в остатке единицу, то добавляем число в сумму

    end;

    write (' сумма положительных нечетных чисел, меньших n = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «найти сумму положительных нечетных чисел, меньших n. по паскалю ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. Программа получает на вход целые числа, кол-во не известно, 0-признак окончания Входные данные: - 7,14,84,0 Составить по Паскалю
Ответы (1)
Найти сумму целых положительных чисел, больших 20, меньших 120 и кратных 9 и не заканчивающих на 5
Ответы (1)
Найти среднее арифметическое чисел стоящих на нечетных местах и подсчитать количество чисел меньших заданного С. Тема: работа с одномерными массивами.
Ответы (1)