Задать вопрос
1 августа, 02:29

Дано трехзначное число. Напишите программу, которая опеределяет Есть ли среди цифр заданного целого трехзначного числа одинаковые

+3
Ответы (1)
  1. 1 августа, 03:01
    0
    Использовано условие: если число сотен равно числу единиц или число сотен равно числу десятков или число десятков равно числу единиц тогда вывести "есть одинаковые цифры", иначе - "нет одинаковых цифр".

    program equal;

    var n: integer;

    begin

    write ('Введите число: ');

    readln (n);

    if (n div 100 = n mod 10) or (n div 100 = (n div 10) mod 10)

    or ((n div 10) mod 10 = (n mod 10))

    then write ('В числе есть одинаковые цифры')

    else write ('В числе нет одинаковых цифр')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано трехзначное число. Напишите программу, которая опеределяет Есть ли среди цифр заданного целого трехзначного числа одинаковые ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Напишите программу, которая определяет, есть ли среди цифр введенного с клавиатуры целого трехзначного числа одинаковые.
Ответы (1)
Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответы (2)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)