Задать вопрос
14 марта, 01:01

сколько чисел в натуральном ряду от 1 до 100000, которые не делятся на числа 2,3,5,7,11,13 и на простое число с номером 11+1 среди простых чисел в натуральном ряду

+3
Ответы (1)
  1. 14 марта, 01:18
    0
    program zz1;

    var a, b, n, c, i:integer; / / задаем переменные целого типа

    begin

    for i:=2 to 1000 do / / находим 12-ое простое число

    begin

    for a: = 1 to i do

    if i mod a = 0 then b:=b + 1;

    if b = 2 then n:=n+1;

    b:=0;

    if n = 11 + 1 then break;

    end;

    c:=i;

    for i:=1 to 100000 do / / считаем количество нужных чисел

    begin

    if (i mod 2 0) and (i mod 3 0) and (i mod 5 0) and (i mod 7 0) and (i mod 11 0) and (i mod 13 0) and (i mod c 0) then b:=b+1;

    end;

    writeln (' количество найденных чисел = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «сколько чисел в натуральном ряду от 1 до 100000, которые не делятся на числа 2,3,5,7,11,13 и на простое число с номером 11+1 среди простых ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найти все трёхзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
Ответы (1)
Каждую букву своего имени мальчик заменил порядковым номером этой буквы в алфавите. Имей ввиду, что буква А имеет номер 1. Буквы с номером 0 нет. Получился код: 510141. Как звали мальчика?
Ответы (1)
Каждую букву своего имени мальчик заменил порядковым номером этой буквы в алфавите. Имей в виду, что буква А имеет номер 1. Буквы с номером 0 нет. Получиться код: 510141 как звали мальчика. d. Девочку зовут Светлана. Зашифруй ее имя тем же способом.
Ответы (1)
Вводятся два числа А и В (В>А). Вывести на экран числа, которые делятся на 3, но не делятся на 5 и их количество. (Паскаль)
Ответы (1)
Составь и запиши двузначные числа из цифр 4, 7, 9 (продолжи). а) Сколько чисел получилось? б) Сколько чётных чисел? в) Сколько нечётных чисел? г) Запиши число с порядковым номером 3 словом (в текстовой форме) :
Ответы (1)