Задать вопрос

Создать массив из 10 случайных чисел от 10 до 50

+3
Ответы (1)
  1. 19 июля, 04:04
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i:integer; / / задаем переменную целого типа для параметра цикла

    m:array [1 ... n] of integer; / / описываем массив

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (41) + 10; / / в функции random получаем диапазон чисел от 0 до 40, а + 10 дает диапазон от 10 до 50

    for i:=1 to n do / / выводим полученный массив из десяти случайных чисел на экран в строчку через пробел

    write (m[i], ' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Создать массив из 10 случайных чисел от 10 до 50 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. То-есть дан массив в которым есть нулевые значения. Например: 20330120 От Вас требуется создать массив из номеров этих нулевых значений.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Помогите с Pascalem ABC. Создать массив из 12 Случайных чисел со значениями от - 23 до 23 Провести его вычислить количество и Сумму чисел кратных 5.
Ответы (1)