Задать вопрос

Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c

+2
Ответы (1)
  1. 19 сентября, 21:14
    0
    var a, b, c, a1, b1, c1 : integer; / переменные целого типа; ma, mb, mc : real; / переменные вещественного типа; function f : real; / функция вещественного типа; begin / блок в котором мы задаем функцию f : = sqrt ((2 * a1 * a1 + 2 * b1 * b1 - c1 * c1) / 4); end; begin write ('a='); readln (a); / Вводим с клавиатуры а; write ('b='); readln (b); / Вводим с клавиатуры b; write ('c='); readln (c); / Вводим с клавиатуры с; a1 : = a; b1 : = b; c1 : = c; mc : = f; / присваем значение, чтобы использовать в функции; a1 : = c; b1 : = b; c1 : = a; ma : = f; a1 : = a; b1 : = c; c1 : = b; mb : = f; writeln ('Медианы равны: ', ma : 1 : 3, ' | ', mb : 1 : 3, ' | ', mc : 1 : 3); / Выводим то что получилось readln end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу вычисления длин медиан треугольника, у которой длины сторон a, b, c ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1. Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное количиство граммов задается с клавиатуры. 2. Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам.
Ответы (1)
Напишите программу нахождения длин медиан m1, m2 и m3, треугольника по указанными формулами. Длина сторон a, b, c задается с клавиатуры m1=1/2*sqrt (2a^2+2b^2-c^2); m2=1/2*sqrt (2a^2+2c^2-b^2); m3=1/4*sqrt (2b^2+2c^2-a^2);.
Ответы (1)
Известны длины сторон треугольника a, b, c. Напишите программу вычисления его площади по формуле Герона. Написать программу в Паскаль
Ответы (1)
Составить программу для вычисления площади треугольника по длинам двух сторон треугольника и ушлу между ними. Составить блок-схему и описание на языке паскаля
Ответы (1)