Задать вопрос

Проггамма паскаль Найти среднее арифметическое не равных нулю элементов масивные X (n, m) и подсчитать количество элементов с неподлжительными значениями

+5
Ответы (1)
  1. 29 марта, 02:06
    0
    var a: array[1 ... 100, 1 ... 100] of integer;

    n, m, i. j, otr, srar, x: integer;

    begin

    writeln ('Введите количество строк массива');

    readln (n);

    writeln ('Введите количество столбцов массива');

    readln (m);

    writeln ('Заполните массив');

    for i:=1 to n do for j:=1 to m do readln (a[i, j]);

    for i:=1 to n do for j:=1 to m do (if a[i, j] > 0) or (if a[i, j] < 0) then begin

    sum:=sum+a[i, j];

    x:=x+1;

    end;

    writen ('Среднее арифметическое ненулевых чисел массива равно', sum mod x);

    for i:=1 to n do for j:=1 to m do if a[i, j]<0 then otr:=otr+1;

    writeln ('Количество отрицательных чисел равно ', otr);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Проггамма паскаль Найти среднее арифметическое не равных нулю элементов масивные X (n, m) и подсчитать количество элементов с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Дан массиа А, состоящий из 12 чисел, массив заполнить случайными числами в диапазоне от 0 до 100. Требуется подсчитать среднее арифметическое значение элементов массива. на экран вывести массив и среднее арифметическое
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)