Задать вопрос

Составьте программу, которая позволяет ввести элементы массива a[1 ... 10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.

+1
Ответы (1)
  1. 25 марта, 04:56
    0
    var a: array [1 ... 10] of integer;

    k, i: integer;

    begin

    k:=0;

    for i: = 1 to 10 do

    begin

    writeln ('Введите ', i, ' элемент массива: ');

    read (a[i]);

    if a[i]<0 then inc (k);

    end;

    writeln ('Отрицательные элементы массива под индексами: ');

    for i: = 1 to 10 do

    if a[i]<0 then write (i, ' ');

    writeln ();

    write ('Кол-во таких элементов = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая позволяет ввести элементы массива a[1 ... 10] с клавиатуры и выводит на экран количество отрицательных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Составить программу, которая позволяет вводить с клавиатуры элементы массива a[1 ... 10] и числа k1 и k2, а затем выводит на экран в одну строку элементы массива с индексами от k1 до k2
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)