Задать вопрос

Дано трёхзначное число, найти его число при прочтении его цифр справа налево паскаль

+3
Ответы (1)
  1. 27 февраля, 08:00
    0
    var

    a, b, i: integer; / / объявляем переменные целочисленного типа.

    s : string; / / объявляем переменную строкового типа.

    begin

    write ('Введите трехзначное число:'); / / вывод строки на экран.

    read (a); / / считываем число, введенное с клавиатуры.

    while a > 0 do / / начало цикла.

    begin

    b : = a mod 10; / / определяем последнюю цифру числа.

    s:=s + inttostr (b); / / сохраняем цифры числа в обратном порядке.

    a : = a div 10; / / удаляем последнюю цифру из числа.

    end;

    write ('Ответ: ', s); / / вывод ответа на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано трёхзначное число, найти его число при прочтении его цифр справа налево паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано трехзначное число. вывести число, полученное при прочтении исходного числа справа налево. через паскальАБС
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 122 - нет 121 - перевертыш 222 - перевертыш
Ответы (1)
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т. е. числом, десяти на запись которого читается одинаково слева направо и справа налево
Ответы (1)