Задать вопрос

Нужно решить через Паскаль с помощью циклов for или while 1) Известно количество пассажиров за каждый месяц. Вычислить ср. арифметическое за год 2) Известно кол-во очков каждого игрока команды. Определить лучшего.

+3
Ответы (1)
  1. 7 апреля, 03:31
    0
    1.

    Progran pass;

    var

    M: array [1 ... 12] of integer;

    n, s, i: integer;

    sr: real;

    begin

    for i:=1 to 12 do

    begin

    write ('Введите число пассажиров в ', i,'-м месяце');

    readln (M[i]);

    end;

    for i:=1 to n do s:=s+M[i];

    sr:=s/12;

    writeln ('Среднее число пассажиров за год: ', sr);

    readln;

    end.

    2.

    Program igr;

    var

    I: array [1 ... 100] of integer;

    d, n, f, j, max: integer;

    begin

    write ('Введите количество игроков: ');

    readln (n);

    for j:=1 to n do

    begin

    write ('Введите число очков ', j,'-го игрока ');

    readln (I[j]);

    end;

    f:=I[1];

    for j:=1 to n do if I[j]>f then

    begin

    max:=I[j];

    f:=j end;

    writeln ('Лучший игрок - №', f);

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нужно решить через Паскаль с помощью циклов for или while 1) Известно количество пассажиров за каждый месяц. Вычислить ср. арифметическое ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень или увеличить число камней в куче в пять раз.
Ответы (1)
Напишите программу на языке Паскаль для задачи: Ввести числа a и b, и вывести квадраты и кубы целых чисел от a до b. (С использованием циклов)
Ответы (1)
Составить программу для нахождения произведение чисел от 1 до n. Для циклов: 1) for 2) while 3) until
Ответы (1)
написать программа выводу на экран всех 3 значных чисел, кратных 6 и 4, и заканчивающихся на цифру 8. Программу писать тремя способами с использованием циклов for, while, repeat
Ответы (1)
Как визуально определить, что команда "не работает"? Вариант 1:по трем точкам в конце команды Вариант 2:по стрелке вправо в конце команды Вариант 3:по "галочке" слева от команды Вариант 4:по цвету строки с командой
Ответы (1)