Задать вопрос

Дан фрагмент программы mov ax, 0Ah mov bx, 0Ah xor ax, bx какое значение будет содержаться в регистре ax? 1) 20 2) 0Ah 3) 0 4) 10

+3
Ответы (1)
  1. 10 августа, 22:52
    0
    Ответ: 3) 0

    xor - это бинарная логическая операция, которая возвращает 1 лишь только тогда, когда один из ее операндов равен 1, а другой - 0. Так как в нашем случае в оба регистра ax и bx заносится одно и то же значение 0Ah, соответствующие разряды которого равны, в результате побитовой операции xor над этими числами мы получаем значение 0 в результирующем регистре ax.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан фрагмент программы mov ax, 0Ah mov bx, 0Ah xor ax, bx какое значение будет содержаться в регистре ax? 1) 20 2) 0Ah 3) 0 4) 10 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Музыкальный фрагмент был передан в город А за 54 с затем этот же фрагмент оцифравали повторно с разрешением в 3 р ниже чем и чистота дискритизации в 4 р выше чем в 1 раз полученный фрагмент бы л передан в гарод В за 36 с во сколько раз пропускная
Ответы (1)
Дан фрагмент программы: a:=0; b:=100; while b>a do begin a:=a+2; b:=b-1; end. Сколько раз будет выполнено тело цикла? Чему в итоге равны значения переменных a и b? Сколько раз будет выполнено тело цикла, если поменять знак на противоположный?
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)