Задать вопрос

Дан ряд двузначных натуральных чисел. Из него вычёркивают числа, состоящие из одинаковых цифр. Составить алгоритм и описать его на доступном вам языке программирование (Basic, Паскаль, Си), позволяющий по заданному номеру N вывести соответствующее ему число в новой последовательности.

+5
Ответы (1)
  1. 17 марта, 13:32
    0
    program arr;

    var a, b: array [1 ... 30] of integer;

    n: integer;

    begin

    randomize;

    for i : integer: = 1 to 30 do

    begin

    a[i]: = random (91) + 9;

    write (a[i] : 3)

    end;

    for i: integer: = 1 to 30 do if a[i] div 10 = a[i] mod 10 then a[i]: = 0;

    writeln ();

    for i: integer: = 1 to 30 do / / создание нового массива

    if a[i] > 0 then

    begin

    n: = n + 1;

    b[n]: = a[i];

    write (b[n] : 3)

    end;

    writeln ();

    write (' Введите номер элемента в новой последовательности (< ', n + 1, ') : ');

    readln (n);

    write (' ', b[n])

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан ряд двузначных натуральных чисел. Из него вычёркивают числа, состоящие из одинаковых цифр. Составить алгоритм и описать его на ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Дан массив, содержащий 70 целых чисел. Опишите алгоритм, позволяющий найти и вывести наименьшее содержащиеся. в массиве положительное число, десятичная запись которого. оканчивается цифрой 7. Гарантируется, что в массиве есть такое число.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)