Войти
Задать вопрос
Даниэль Щеглов
Информатика
1 сентября, 02:48
Найти сумму цифр любого числа с помощью String
+5
Ответы (
1
)
Георгий Морозов
1 сентября, 05:38
0
program zz1;
var s:string; / / задаем переменную строкового типа
i, p, k:integer; / / задаем переменные целого типа
begin
write (' введите заданное число ');
read (s); / / вводим с клавиатуры строку
for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего
begin
p:=strtoint (s[i]); / / преобразуем цифру числа из строкового типа в числовой
k:=k + p; / / прибавляем цифру из числа к сумме
end;
write (' сумма цифр введенного числа = ', k);
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«Найти сумму цифр любого числа с помощью String ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
В чём ошибка этой программы? Она должна запрашивать ввод 2 чисед, а потом вызывать функцию с помомщью которой выведет сумму и разность числа var a, b, c:string; procedure summ (plus:string; minus:string); Begin plus:=a+b; minus:=a+b;
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Написать программу в паскаль "найти сумму цифр сколь угодно значного целого числа". Использовать string
Ответы (1)
Задан список из десяти городов. (array [.]of string) Подсчитать количество названий, в которых нет буквы "р".
Ответы (1)
Выберите возможные типы переменной k для внесения в неё значения "-1,3" a) integer b) real c) boolean d) string
Ответы (1)
Нужен ответ
Из данных слов Выпиши имена существительные сильный зима, найти, дерево, рисовать, красивый, воробей, река, ручной, решать, подснежник, показаться.
Нет ответа
В санатории привезли апельсины мандарины и лимоны апельсины составляет пять четырнадцатых всех фруктов мандарины восемь 21-й, а лимоны остальные 99 кг сколько килограммов фруктов привезли в санаторий
Нет ответа
Расположите числа 5,28; - 1,634; - 1,34; - 1, (3); 2,3 (4) и 2, (34) в порядке убывания
Нет ответа
сравнить природные условия финикии древнего египта и индии
Нет ответа
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Главная
»
Информатика
» Найти сумму цифр любого числа с помощью String
Войти
Регистрация
Забыл пароль