Задать вопрос

найти сумму элементов массива х = (3.5; - 6.3; 2.1; 0.1; 5.1; - 2.1), значения которых меньше 0.25 к данному заданию составить алгоритм и написать программу на языке Pascal

+2
Ответы (1)
  1. 17 августа, 03:18
    0
    program zz1;

    const n = 6; / / задаем количество элементов в массиве

    m:array [1 ... n] of real = (3.5, - 6.3, 2.1, 0.1, 5.1, - 2.1); / / описываем массив и задаем значение его элементов

    var i:integer; / / задаем переменную целого типа

    s:real; / / задаем переменную не целого типа

    begin

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if (m[i] < 0.25) then s:=s + m[i];

    writeln (' сумма элементов меньших заданного числа = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «найти сумму элементов массива х = (3.5; - 6.3; 2.1; 0.1; 5.1; - 2.1), значения которых меньше 0.25 к данному заданию составить алгоритм и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить алгоритм и программу подсчитывающую количество меньших чем соседние элементов массива Z из 13 чисел. Значения элементов массива рассчитать по формуле WSinW, где W номер элемента массива
Ответы (1)
Дан массив B, в котором содержится 10 элементов целого типа. Найти: А) сумму элементов этого массива Б) произведение элементов этого массива В) Среднее арифметическое этого массива Нужен алгоритм паскаль Например: Program Summa; Var B:array (1 ...
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Cделать программу в Pascal по заданию:"Найти в двумерном массиве сумму массива, сумму элементов по столбцам и среднее арифметическое по строкам"
Ответы (1)