Задать вопрос

Составьте программу для решения следующей задачи: задан массив В, состоящий из х чисел. Выведете на экран элементы противоположные элементам данного массива. Первоначально элементы вводятся случайно из промежутка [-17; 17]

+1
Ответы (1)
  1. 19 ноября, 12:08
    0
    program zz1;

    const n = 15; / / задаем количество элементов в массиве

    var i, k, s:integer; / / задаем переменные целого типа

    B:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    B[i]:=random (35) - 17;

    for i:=1 to n do / / выводим полученный массив на экран

    write (B[i]:4);

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do / / организуем цикл

    B[i]:=B[i] * (-1);

    for i:=1 to n do / / выводим полученный массив на экран

    write (B[i]:4);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу для решения следующей задачи: задан массив В, состоящий из х чисел. Выведете на экран элементы противоположные ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Составьте паскаль-программу для решения следующей задачи: "Дан одномерный массив действительного типа. Получить другой массив, состоящий только из чисел исходного массива, больших данного числа N, или сообщить, что таких чисел нет.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)