Задать вопрос

Дан одномерный массив состоящий из 10 элементов. Найти кол во чисел кратных 7

+2
Ответы (1)
  1. 10 апреля, 14:39
    0
    program zz1;

    var i, kol:integer;

    mas:array[1 ... 10] of integer;

    begin

    for i:=1 to 10 do / /заполняем массив числами с клавиатуры через пробел

    read (mas[i]);

    for i:=1 to 10 do

    if mas[i] mod 7 = 0 then kol:=kol+1; / /проверяем, если число дклится на 7 без остатка, то считаем его

    write ('количество чисел кратных 7=', kol); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан одномерный массив состоящий из 10 элементов. Найти кол во чисел кратных 7 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым способом
Ответы (1)