Задать вопрос

Написать программу: Вывести на экран первых N простых чисел.

+1
Ответы (1)
  1. 26 сентября, 19:36
    0
    program zz1;

    var i, k, n, c, p: integer; / / задаем переменные целого типа

    begin

    write (' введите число n '); / / вводим с клавиатуры число

    read (n);

    k : = 1; / / задаем начальное значение для простого числа

    p: = 0; / / задаем начальное значение для количества простых чисел

    while p < n do / / организуем цикл, пока количество простых чисел не достигнет n

    begin

    c: = 0;

    for i : = 1 to k do

    begin

    if k mod i = 0 then inc (c)

    end;

    if c = 2 then begin

    write (k, ' ');

    inc (p); / / увеличиваем количество простых чисел

    end;

    inc (k);

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу: Вывести на экран первых N простых чисел. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
По заданному числу K (от 0 до 10) вывести его название. Например при K=2 вывести на экран , при K=3 вывести на экран и т. д
Ответы (1)