Задать вопрос

Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном порядке, все символы, расположенные на нечетных позициях.

+4
Ответы (1)
  1. 18 октября, 00:03
    0
    program zz1;

    var s, s1:string; / / задаем переменные строкового типа

    i, m, k:integer; / / задаем переменные целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    s1:='';

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    if i mod 2 = 0 then s1:=s1+s[i]; / / проверяем, если номер символа четный, то прибавляем его к новой строке

    for i:=length (s) downto 1 do / / организуем цикл, в котором переберем все символы от последнего до первого

    if i mod 2 = 1 then s1:=s1+s[i]; / / проверяем, если номер символа нечетный, то прибавляем его к новой строке

    writeln (' полученная зашифрованная строка = ', s1); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана строка-предложение. Зашифровать ее, поместив вначале все символы, расположенные на четных позициях строки, а затем, в обратном ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана исходная строка: "12". Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных позициях считая слева направо, прибавили по 1. Получилась строка: "1322".
Ответы (1)
Дано предложение. Напечатать все символы, расположенные между 1 и 2 запятой. Если 2 запятой нет, то должны быть напечатаны все символы, расположенные после единственной запятой.
Ответы (1)
В начальный момент времени записана цифра 0. На каждом из следующих девяти шагов выполняются такие действия: в очередную строку записывается следующая по порядку цифра, после чего записывается предыдущая строка в обратном порядке.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки.
Ответы (1)