Задать вопрос

Дано натуральное четырехзначное число n. Найти сумму его цифр.

+5
Ответы (1)
  1. Решим данную задачи на основе применения функций целочисленного деления DIV (целочисленный результат деления двух чисел) и MOD (остаток от целочисленного деления двух чисел).

    Алгоритм решения данной задачи линейный, с последовательным определением значащих цифр числа (слагаемые в вычислительном выражении).

    Program SummaCifr4;

    var a, s : integer; begin readln (a); s : = a div 1000 + (a div 100) mod 10 + (a div 10) mod 10 + a mod 10; writeln (s); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное четырехзначное число n. Найти сумму его цифр. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано четырехзначное число. определить равна ли сумма первых двух его цифр сумме двух его последних цифр. В паскале
Ответы (1)
Дано четырехзначное число. Написать программу, которая определяет равна ли сумма первых двух его цифр сумме двух его последних цифр.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)