Задать вопрос

Дан одномерный массив целых чисел. Написать программу подсчёта количества положительных и отрицательных чисел массива.

+2
Ответы (1)
  1. 18 февраля, 14:35
    0
    program zz1;

    const n = 10; / / задаем количество чисел в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    begin

    if m[i] < 0 then s:=s + 1; / / проверяем, если очередной элемент массива отрицательный, то считаем его

    if m[i] > 0 then k:=k + 1; / / проверяем, если очередной элемент массива положительный, то считаем его

    end;

    writeln (' количество отрицательных элементов массива = ', s); / / выводим ответ

    writeln (' количество положительных элементов массива = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан одномерный массив целых чисел. Написать программу подсчёта количества положительных и отрицательных чисел массива. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)