Задать вопрос

Ввести 2 числа. Если их произведение отрицательно, умножить его на - 2 и вывести на экран, в противном случае увеличить его в 3 раза и вывести на экран.

+2
Ответы (1)
  1. 20 декабря, 03:30
    0
    program zz1;

    var a, b:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    if a * b < 0 / / проверяем, если произведение этих чисел будет отрицательным, то

    then write (' произведение двух чисел умноженное на - 2 = ', a * b * - 2) else write (' произведение двух чисел увеличенное на 3 = ', a + b + 3);

    / / выводим ответ в зависимости от правильности условия

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести 2 числа. Если их произведение отрицательно, умножить его на - 2 и вывести на экран, в противном случае увеличить его в 3 раза и ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Ввести число если оно не отрицательно вычесть из него 50, в противном случае прибавить к нему 100. Решение
Ответы (1)
Ввести 2 целых числа. Вывести их произведение, если они разных знаков и их сумму в противном случае. Написать программу, которая бы решила эту задачу.
Ответы (1)
Обозначим символом Z бит, определяющий факт равенства результата R нулю, а символом N - бит, фиксирующий отрицательность R: Z = 1 при R = 0, иZ=0 в противном случае; N = 1 при ЯR О, и 0 в противном случае.
Ответы (1)