Задать вопрос
17 сентября, 17:57

Ввести 2 целых числа. Вывести их произведение, если они разных знаков и их сумму в противном случае. Написать программу, которая бы решила эту задачу.

+2
Ответы (1)
  1. 17 сентября, 19:20
    0
    program zz1;

    var a, b:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / /вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / /вводим с клавиатуры второе число

    read (b);

    if a * b < 0 / / проверяем, если числа разных знаков, то произведение этих чисел будет отрицательным и получаем произведение чисел, иначе - сумму

    then write (' произведение двух чисел = ', a * b) else write (' сумма двух чисел = ', a + b);

    / / выводим ответ в зависимости от правильности условия

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести 2 целых числа. Вывести их произведение, если они разных знаков и их сумму в противном случае. Написать программу, которая бы решила ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести 2 числа. Если их произведение отрицательно, умножить его на - 2 и вывести на экран, в противном случае увеличить его в 3 раза и вывести на экран.
Ответы (1)
Ввести с клавиатуры 2 целых числа: m, n. Если n ≤ m, то вывести 1, в противном случае - любое другое число. Напишите программу в Паскаль.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)