Задать вопрос

Программу в паскале. Составить программу нахождения произведения положительных чисел одномерного массива В (10), элементы которого задаются датчиком случайных чисел.

+2
Ответы (1)
  1. 30 октября, 07:31
    0
    program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, s:int64; / / задаем переменные целого типа

    b:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    b[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (b[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    s:=1;

    for i:=1 to n do

    if b[i] > 0 then s:=s * b[i]; / / получаем произведение

    writeln (' произведение положительных элементов = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Программу в паскале. Составить программу нахождения произведения положительных чисел одномерного массива В (10), элементы которого задаются ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Найдите наибольший элемент одномерного массива, состоящего из 12 элементов. Элементы задаются датчиком случайных чисел из интервала [-25,31] 2. Массив А вводится с клавиатуры.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Найти наибольший элемент массива размером МхN, элементы которого задаются датчиком случайных чисел на интервале [-25; 19].
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Вычислите сумму элементов одномерного массива А (10). 2) Вычислите произведение элементов одномерного массива А (10). 3) Вычислите сумму четных чисел в массиве А (10). 4) Задан массив из N элементов. Определить максимальный (минимальный) элемент.
Ответы (1)