Задать вопрос

Для целочисленного массива из 20 элементов вычислить количество элементов равных среднему арифметическому элементу массива (диапазон значений: от - 10 до 15)

+4
Ответы (1)
  1. 26 сентября, 11:07
    0
    Код на С++

    #include

    #include

    #include

    #include

    using namespace std;

    void main ()

    {

    SetConsoleCP (1251);

    SetConsoleOutputCP (1251);

    srand (time (NULL));

    int const N = 20;

    int sred, count=0, sum=0;

    int mas[N];

    for (int i = 0; i < N; i++)

    {

    mas[i] = rand () % 26 - 10;

    sum + = mas[i];

    }

    sred = sum / N;

    for (int i = 0; i < N; i++)

    {

    if (sred = = mas[i])

    count++;

    cout << mas[i] << " ";

    }

    cout << endl << "Среднее арифметическое: " << sred << endl;

    cout << "Количество элементов равных среднему арифметическому: " << count << endl;

    system ("pause");
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Для целочисленного массива из 20 элементов вычислить количество элементов равных среднему арифметическому элементу массива (диапазон ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Дан массив, содержащий 2016 неотрицательных целых чисел. Необходимо найти в этом массиве количество таких элементов, которые равны среднему арифметическому двух элементов, расположенных непосредственно перед ним.
Ответы (1)
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)