Задать вопрос
18 октября, 11:00

Дано натуральное число N и последовательность целых чисел a1 a2 an заданные случайным образом из диапазона [-35; 25]. Удвоить все отрицательные числа нечётные этой последовательности. Решить задачу для n=10

+1
Ответы (1)
  1. 18 октября, 12:27
    0
    program zz1;

    const n=10;

    var mas:array[1 ... n] of integer;

    i:integer;

    begin

    for i:=1 to n do

    mas[i]:=random (61) - 35; / /заполняем массив случайными числами

    for i:=1 to n do

    write (mas[i],' '); / /выводим их на экран

    for i:=1 to n do

    if (mas[i] mod 2=-1) then mas[i]:=mas[i]*2; / /умножаем на 2 те, которые отрицательные и нечетные

    writeln; / /переходим на новую строку

    for i:=1 to n do

    write (mas[i],' '); / /выводим числа на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число N и последовательность целых чисел a1 a2 an заданные случайным образом из диапазона [-35; 25]. Удвоить все ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
написать программу в паскале Из диапазона от 10 до 1000 компьютер выбрал случайным образом число. Если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное ПК и новое, полученное после
Ответы (1)
Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [-6; 9]. И вывести все элементы массива на экран.
Ответы (1)
Дан массив из 10 целых элементов из диапазона [-10; 7]. переписать в другой массив все нечетные элементы. при этом вывести исходный и полученный массив
Ответы (1)
Сформировать матрицу размером 5*8 случайным образом из диапазона значений 0-10. вывести ее на экран и определить количество элементов больших пяти в третьем столбце и их сумм если таких элементов нет то указать что они отсутствуют
Ответы (1)