Задать вопрос
17 января, 11:45

P = (1+1/1) (1+1/2) ... (1+1/N) составить программу вычисления. на языке паскаль.

+5
Ответы (1)
  1. 17 января, 12:07
    0
    В программе использован цикл for, потому что число операций умножения известно - оно равно введенному числу N.

    program prod;

    var N, i: integer; / /число и параметр цикла

    p: real;

    begin

    writeln ('Введите число N');

    readln (N); / /ввод числа N

    p: = 1; / / начальное значение произведения

    for i: = 1 to N do p:=p * (1+1/i);

    writeln (p);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «P = (1+1/1) (1+1/2) ... (1+1/N) составить программу вычисления. на языке паскаль. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Написать на языке паскаль программу ввода четырех целых чисел и вычисления их среднего арифметического. протестировать программу на различных исходных данных и доказать правильность ее работы
Ответы (1)
Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс
Ответы (1)
Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N? Вообще с Паскалем у меня полный завал! Если знаете как, то напишите! Желательно с объяснениями, буду благодарна!
Ответы (1)