Задать вопрос

Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива. I=1,2,3 ... 10

+4
Ответы (1)
  1. 1 июля, 19:23
    0
    Var a:array[1 ... 10]of Integer;

    i, k:Integer;

    p:LongInt;

    begin

    p:=1;

    k:=0;

    Writeln ('Сгенерированный массив:');

    Randomize;

    for i:=1 to 10 dobegina[i]:=Random (10) + 1; if a[i] mod 2=1 then p:=p*a[i] else k:=k+1;

    Write (a[i],' ');

    end;

    Writeln;

    Writeln ('Произведение нечетных:', p);

    Writeln ('Количество четных:', k);

    Readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Сформировать целочисленный массив из 12 произвольных чисел. Получить новый массив, который отличается от исходного тем, что все элементы исходного массива с четными номерами удвоены, а с нечетными - заменены единицей
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)