Задать вопрос

Дана последовательность чисел: 26, - 53, 0, - 67, 12, - 34, 0, 90, 14, - 78, 0, - 45, 66. Найди количество отрицательных чисел, сумму положительных чисел, среднее значение.

+3
Ответы (1)
  1. 3 ноября, 04:20
    0
    program zz1;

    const n = 13; / / задаем количество элементов в массиве

    R:array [1 ... n] of integer = (26, - 53, 0, - 67, 12, - 34, 0, 90, 14, - 78, 0, - 45, 66); / / задаем последовательность чисел

    var i, k, m:integer; / / задаем переменные целого типа

    begin

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    begin

    if R[i] < 0 then k:=k + 1; / / проверяем, если элемент отрицательный, то считаем его

    if R[i] > 0 then m:=m + R[i]; / / проверяем, если элемент положительный, то добавляем элемент в сумму

    end;

    writeln (' количество отрицательных = ', k); / / выводим ответ

    writeln (' сумма положительных = ', m);

    writeln (' среднее значение = ', m/13);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана последовательность чисел: 26, - 53, 0, - 67, 12, - 34, 0, 90, 14, - 78, 0, - 45, 66. Найди количество отрицательных чисел, сумму ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)