Задать вопрос

Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет

+4
Ответы (1)
  1. var

    mas: array[1 ... 10] of real;

    i, n: integer;

    sum: real;

    begin

    for i:=1 to 10 do

    begin

    write ('Введите ', i,'-ое число: ');

    readln (mas[i]);

    end;

    n:=0;

    sum:=0;

    / / если число меньше нуля увеличиваем количество отрицательных - n

    / / иначе увеличиваем сумму положительных sum

    for i:=1 to 10 do

    if mas[i]<0 then n:=n+1

    else sum:=sum+mas[i];

    writeln ('Количество отрицательных чисел ', n);

    / / если сумма положительных чисел больше нуля выводим ее значение

    / / иначе выводим сообщение, что положительных чисел нет

    if sum>0 then writeln ('Сумма положительных чисел равна ', sum)

    else writeln ('Положительных чисел не было.');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Написать программу в Паскале: В массиве из N действительных чисел, введённых с клавиатуры, найти номер первого отрицательного элемента и выдать на экран этот элемент или сообщение о том, что в массиве отрицательных элементов нет.
Ответы (1)
Введите с клавиатуры одномерный массив А (N), элементами которого являются положительные и отрицательные целые числа. Подсчитайте произведение положительных элементов этого массива и количество отрицательных.
Ответы (1)