Задать вопрос
15 января, 14:40

Упорядочить нечетные элементы массива по убыванию (тема: метод перестановок или пузырька)

+3
Ответы (1)
  1. 15 января, 15:43
    0
    Создадим массив, который будет иметь тип real, чтобы было больше возможностей для его заполнения, и назовем его В:

    B : array [1 ... 110] of real;

    Заполним его случайными числами со специальной функцией:

    for i:integer : = 1 to 110 do

    B[i] : = random (100) / 5 + random (100) / 2;

    Будем упорядочивать:

    for i:integer : = 2 to 110 do

    if (B[i] < B[i - 1]) then

    begin

    t : = B[i - 1];

    B[i - 1] : = B[i];

    B[i] : = t;

    end;

    После этого все элементы станут в массиве по порядку.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Упорядочить нечетные элементы массива по убыванию (тема: метод перестановок или пузырька) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
За какое наименьшее количество перестановок можно упорядочить по возрастанию или по убыванию последовательность цифр 634251? Переставить - это значит поменять местами две цифры. А) 2 Б) 3 В) 4 Г) 5
Ответы (1)
Дан массив С размеров 10 элементов, элементы вводятся с клавиатуры. а) Найти сумму отрицательных элементов массива б) Поменять 1 и 5 элементы местами в) выполнить сортировку массива по возрастанию методом "пузырька"
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)