Задать вопрос

Ввести с клавиатуры двузначное целое число и определить какая из его цифр больше. (Ответ "Первая цифра","Вторая цифра" или "Равны").

+5
Ответы (1)
  1. 23 декабря, 02:35
    0
    program zz1;

    var k, s, n:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное двузначное целое число ');

    read (k);

    s:=k div 10; / / получаем первую цифру двузначного целого числа

    n:=k mod 10; / / получаем вторую цифру двузначного целого числа

    if s > n then write (' Первая цифра '); / / проверяем условие и выводим ответ, если условие верное

    if s < n then write (' Вторая цифра '); / / проверяем условие и выводим ответ, если условие верное

    if s = n then write (' Равны '); / / проверяем условие и выводим ответ, если условие верное

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ввести с клавиатуры двузначное целое число и определить какая из его цифр больше. (Ответ "Первая цифра","Вторая цифра" или "Равны"). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
1) Ввести с клавиатуры целое число. Определить четное оно, или нечетное. 2) Решить следующие задачи: Является ли треугольник с длинами сторон a, b, c : * прямоугольным; * равнобедренным; * равносторонним. Стороны вводятся с клавиатуры.
Ответы (1)
1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1
Ответы (1)