Задать вопрос
31 октября, 17:54

Написать программу по Паскале. Вычислить сумму чисел от 19 до 51, если они делятся на 5.

+1
Ответы (1)
  1. 31 октября, 19:52
    0
    1-й вариант:

    Pascal (for)

    var sum : integer;

    i: integer;

    begin

    sum : = 0;

    i : = 0;

    for i:=19 to 51 do

    begin

    if i mod 5 = 0 then

    sum : = sum + i;

    end;

    writeln (sum);

    end.

    2-й вариант:

    Pascal

    var sum : integer;

    i: integer;

    begin

    sum : = 0;

    i : = 19;

    while (i < = 51) do

    begin

    if i mod 5 = 0 then

    sum : = sum + i;

    i : = i + 1;

    end;

    writeln (sum);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу по Паскале. Вычислить сумму чисел от 19 до 51, если они делятся на 5. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы