Задать вопрос
12 октября, 22:08

1) Найти сумму 1/2+1/4+1/6 ... 1/20 на паскале с помощью while и точно такую же задачу с циклом for2) Возведение степени a в степень n, с помощью while

+3
Ответы (1)
  1. 13 октября, 00:52
    0
    1.1) Program summawhil;

    var

    i, sum:integer;

    begin

    i:=2;

    while i<21 do

    begin

    sum:=sum+1/i;

    i:=i+1;

    end;

    writeln (sum);

    end.

    1.2) Program summafo;

    var

    i, sum:integer;

    begin

    for i:=2 to 20 do

    begin

    sum:=sum+1/i;

    end;

    writeln (sum);

    end.

    2) Program stepen;

    var

    a, n:integer;

    begin

    readln (a); {ввод значения числа а}

    readln (n); {ввод значения степени n}

    while n>1 do

    begin

    a:=a*a;

    n:=n-1;

    end;

    writeln (a);

    end.

    Если во 2 задании вводить не нужно, напишите а: = (ваше число) и n: = (ваше число) вместо строк 5 и 6.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Найти сумму 1/2+1/4+1/6 ... 1/20 на паскале с помощью while и точно такую же задачу с циклом for2) Возведение степени a в степень n, с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Найдите сумму всех натуральных чисел на промежутке от 1 до n. Число n вводится на клавиатуре. Составьте на Паскале с циклом WHILE
Ответы (1)
В паскале напишите программу с циклом while. y=x+4. На образце x принадлежит [-5,5] / C шагом 2.
Ответы (1)
Вводится последовательность 14 чисел. Определить сколько среди них не отрицательных и сколько отрицательных чисел. Составьте алгоритм на Паскале с циклом WHILE
Ответы (1)
В классическом паскале нет функции возведения в степень. Если программисту на паскале все же потребуется возвести число a>0 в степень n, то с помощью какого выражения он может это сделать?
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)