Задать вопрос

Пользователь вводит натуральное число. Является ли оно степенью числа 3. Если да, то какой.

+2
Ответы (1)
  1. 18 марта, 15:46
    0
    program n_3;

    var p, n, cn, o: integer;

    begin

    write ('Введите целое число - ');

    readln (n);

    cn : = n;

    p : = 0;

    while (n div 3) > 0 do

    begin

    o : = n mod 3;

    if o = 0 then

    begin

    n : = n div 3;

    p : = p + 1

    end

    else n : = 1

    end;

    if o >0 then writeln (cn, ' не может быть представлено, как целая степень числа 3')

    else writeln (cn, ' = ', '3^', p)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Пользователь вводит натуральное число. Является ли оно степенью числа 3. Если да, то какой. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Пользователь работал с каталогом Лирика. Сначала он поднялся на один уровень вверх, затем спустился в какой-то подкаталог текущего каталога. В результате пользователь оказался каталоге C:/Библиотека/Проза.
Ответы (1)
Перемещаясь из одного каталога в другой, пользователь последовательно посетил каталоги INF, MY, EXAM, A:/, TASK, MAIL. При каждом перемещении пользователь либо спускался в каталог на уровень ниже, либо поднимался на уровень выше.
Ответы (1)
Написать программу, в которую пользователь вводит число а компьютер выводит сообщение о том в каком интеревале оно лежит 1 до 10, от 11 до 20, от 21 до 30, и 31 до 40, В паскале.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Решить задачу. Пользователь вводит 2 числа, вывести на экран максимальное и минимальное из этих 2 чисел. Если числа равны, вывести на экран "a=b".
Ответы (1)