Задать вопрос

Написать в программе Паскаль: Дано целое число. Если оно положительное и трехзначное, найти сумму первой и третьей цифры этого числа, в противном случае сообщить, что число нам не подходит.

+4
Ответы (1)
  1. 27 февраля, 22:49
    0
    program zz1;

    var a, b, c, d:integer; / / задаем переменные целого типа

    begin

    write (' введите число '); / / вводим с клавиатуры число

    read (a);

    if (a > 0) and (a > 99) and (a < 1000) then / / проверяем условие, если число положительное и трехзначное

    begin

    b:=a mod 10; / / находим третью цифру числа

    c:=a div 100; / / находим первую цифру числа

    d:=b + c; / / находим сумму цифр

    write (' сумма первой и третьей цифры числа = ', d); / / выводим один ответ

    end

    else

    writeln (' число нам не подходит '); / / выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать в программе Паскаль: Дано целое число. Если оно положительное и трехзначное, найти сумму первой и третьей цифры этого числа, в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)
Написать в программе Паскаль: Дано целое число. Если оно двузначное, найти сумму его цифр.
Ответы (1)