Задать вопрос

1. Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal

+1
Ответы (1)
  1. 4 января, 17:12
    0
    program kvadrat_summy;

    var a, b, c:integer;

    begin

    read (a); {в переменную a будет вводиться значение разряда десятков}

    read (b); {в переменную b будет вводиться значение разряда единиц}

    c : = (a + b) * (a + b); {переменной с присваивается результат, равный квадрату суммы цифр - значений разрядов}

    writeln (c) {выводится результа - значение переменной с}

    end.

    Так выглядит текст программы. По условиям задаем 3 целочисленных переменных (a, b, c).

    После запуска программы вводится значение переменной а, затем - переменной b, программа выдает результат.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Оператор mob (a, b) - находит остаток отделения целого числа а на целое число b, например:mob (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например:div (25,4) = 6.
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)