Задать вопрос

Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1. В ответе запишите найденное число без пробелов и знаков препинания.

+5
Ответы (1)
  1. 28 августа, 04:54
    0
    program zz1;

    var x:integer; / / задаем переменную целого типа

    begin

    x:=1; / / задаем начальное значение искомого числа

    while x< = 1000000 do / / организуем цикл до достаточно большого числа

    begin

    if (x mod 10 = 9) and (x mod 9 = 8) and (x mod 8 = 7) and (x mod 7 = 6) and (x mod 6 = 5) and (x mod 5 = 4) and (x mod 4 = 3) and (x mod 3 = 2) and

    (x mod 2 = 1) then break; / / проверяем условие поиска, если это условие окажется верным, это означает, что искомое число найдено, и выходим аварийно из цикла

    x:=x + 1; / /берем следующее число

    end;

    write (x); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Оператор mob (a, b) - находит остаток отделения целого числа а на целое число b, например:mob (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например:div (25,4) = 6.
Ответы (1)
Составить программу которая находит наименьшее натуральное число n при котором 2n>=20 и результат наименьшее число n выводит на экран
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
1) Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими соотношениями:F (1) = 1, F (2) = 1F (n) = F (n-2) * (n-1) + 2, при n > 2 Чему равно значение функции F (8) ? В ответе запишите только натуральное число.
Ответы (1)
Укажите понятия, определяемые следующими словами (запишите в прямоугольниках). а) Группа слов, которая выражает законченную мысль: б) Значимая часть слова, которая стоит после корня и служит для образования новых слов: в) Часть речи, которая
Ответы (1)