Задать вопрос
29 марта, 17:08

Дано трехзначное число. проверить будет ли сумма его цифр четным числом. на Pascal abc

+4
Ответы (1)
  1. 29 марта, 21:00
    0
    Program dsff;

    uses crt;

    var a, b, c, s: integer;

    begin

    readln (a);

    s:=0;

    b:=a mod 10;

    a:=a div 10;

    c:=a mod 10;

    a:=a div 10;

    s:=a+b+c;

    if ((s mod 2) = 0) then writeln ('четное');

    else writeln ('нечетное');

    readln;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано трехзначное число. проверить будет ли сумма его цифр четным числом. на Pascal abc ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано трехзначное число определить является ли сумма его цифр двухзначным числом, является ли произведение его чисел трехзначным числом, кратно ли сумма его цифр числу 3
Ответы (1)
Дано 3-х значное число N. Проверить, будет ли сумма его цифр чётным числом.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)