Войти
Задать вопрос
Леонид Васильев
Информатика
5 сентября, 19:09
чем отличаются операторы read и readln
+3
Ответы (
1
)
Виктор Окулов
5 сентября, 22:30
0
Операторы read и readln в Паскале предназначены для ввода значений переменных величин, с клавиатуры.
Оператор read читает числа записанные в строчку подряд через пробел.
Например: read (a, b);
Ввод: 2 3 4
Прочитает в переменную а = 2, в переменную b = 3.
Оператор readln читает числа записанные в строчку подряд через пробел и по окончании переходит на новую строку для чтения.
Например: read (a, b, c);
Ввод: 2 3
4
Прочитает в переменную а = 2, в переменную b = 3, в переменную с = 4.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆
«чем отличаются операторы read и readln ...»
по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m'); readln (c, m); s:=c*m; writeln ('s=', s); readln; end.
Ответы (1)
Верна ли следующая программа? Если да, то сколько операторов она содержит, если нет, то почему: var x, y:integer; begin readln (y);; x:=0; if x>0 then; writeln (x, y); readln; end.
Ответы (1)
Program n_1; Var a, b, x, y: real; Begin Writeln ('Введите a') readln (x); Writeln ('Введите b') readln (b); y:=3*x*x+x-4; While x
Ответы (1)
Напишите программу на вычитание, деление и умножение (8-9 класс) На примере: program n_1 uses crt var a, b, c: integar; begin writeln ('введите а: '); readln (а); writeln (введите b: '); readln (b); c:=a+b writeln ('сумма = ', c); readkey; end.
Ответы (1)
Исправить все ошибки допущенные в программе Program Task_1_11; Var a; b; c; Integer; Begin Writeln (' Введите число ', a); Readln (a) b = 5; c: = ab; Writeln (' произведение ' a и b ' равно ', 5); Readln (a); End.
Ответы (1)
Нужен ответ
Расстояние между двумя пунктами 40 км. Из одного из них в другой одновременно въезжают автобус и велосипедист. Скорость автобуса 50 км в час, велосипедиста 10 км в час.
Нет ответа
Известно, что sina+cosa=a. Найдите sin2a
Нет ответа
Решите уравнение (x^2-5x+7) ^2 - (x-2) (x-3) = 1
Нет ответа
дан параллелограм АВСD. O-точка пересечения диагоналей. Найдите векторы OD-OC, 2BO + DA, CD+DB+BA
Нет ответа
1/2 это ... 4 1/3 это ... (в десятичных дробях)
Нет ответа
Главная
»
Информатика
» чем отличаются операторы read и readln
Войти
Регистрация
Забыл пароль