Задать вопрос

Написать программу для следующей задачи: в матрице А (8,8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями.

+4
Ответы (1)
  1. 19 сентября, 13:54
    0
    Pascal:

    var i, j, n:integer;

    a:array[1 ... 1000,1 ... 1000]of integer;

    begin

    read (N);

    for i:=1 to n do

    for j:=1 to n do a[i, j]:=random (1, n);

    for i:=1 to n do

    for j:=i to n do

    a[i, j]:=0;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (a[i, j]:4);

    writeln;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу для следующей задачи: в матрице А (8,8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу для решения следующей задачи: дана квадратная матрица порядка N. Заменить единицами все элементы, стоящие на главной диагонали и выше ее.
Ответы (1)
Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массива
Ответы (1)
Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.
Ответы (1)
Составьте программу для решения следующей задачи: задан массив В, состоящий из х чисел. Выведете на экран элементы противоположные элементам данного массива. Первоначально элементы вводятся случайно из промежутка [-17; 17]
Ответы (1)
Дана квадратная матрица порядка N. В матрице вычислить среднее арифметическое положительных элементов, стоящих на главной диагонали.
Ответы (1)