Задать вопрос

1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.

+5
Ответы (1)
  1. 18 декабря, 04:15
    0
    1. program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    writeln (' двузначные числа массива: '); / / выводим ответ

    for i:=1 to n do

    if (m[i]>9) and (m[i]<100) then write (m[i],' ');

    end.

    2. program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    writeln (' четные числа массива: '); / / выводим ответ

    for i:=1 to n do

    if m[i] mod 2 = 0 then write (m[i],' '); end.

    3. program zz1;

    const n = 5; / / задаем количество элементов в массиве

    var i, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if i mod 2 = 0 then m[i]:=m[i]*2;

    for i:=1 to n do

    if i mod 2 = 1 then m[i]:=m[i]-1;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n чисел.
Ответы (1)
Сформировать целочисленный массив из 12 произвольных чисел. Получить новый массив, который отличается от исходного тем, что все элементы исходного массива с четными номерами удвоены, а с нечетными - заменены единицей
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)