Задать вопрос

Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления произведения элементов массива, которые не четны и делятся на 3.

+2
Ответы (1)
  1. 9 октября, 23:58
    0
    var a:array[0 ... 100] of integer; i, j, p:integer; begin for i:=0 to 5 do readln (a[i]); for i:=0 to 5 do begin for j:=i+1 to 4 do if (a[i] mod 3 = 0) and (a[i] mod 2 0) then if (a[j] mod 3 = 0) and (a[j] mod 2 0) then begin p:=a[j]*a[i]; write (p,' '); end; end; end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан целочисленный массив состоящий из элементов, элементы массива принимают значение от 0 до 100. Составьте программу для вычисления ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым способом
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны
Ответы (1)